[
https://issues.apache.org/jira/browse/FINERACT-2491?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]
Adam Saghy updated FINERACT-2491:
---------------------------------
Fix Version/s: 1.15.0
> Refactor SavingsEnumerations to use switch expression instead of if-else
> chains
> -------------------------------------------------------------------------------
>
> Key: FINERACT-2491
> URL: https://issues.apache.org/jira/browse/FINERACT-2491
> Project: Apache Fineract
> Issue Type: Improvement
> Reporter: abdelrahman
> Priority: Minor
> Fix For: 1.15.0
>
>
> The SavingsEnumerations class currently uses chains of if-else statements in
> the savingEnumueration() method, which reduces code readability and
> maintainability. This refactoring replaces the if-else chain with a switch
> expression to improve readability and maintainability.
--
This message was sent by Atlassian Jira
(v8.20.10#820010)