[ 
https://issues.apache.org/jira/browse/FLINK-7361?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16118571#comment-16118571
 ] 

Nico Kruber commented on FLINK-7361:
------------------------------------

I did some more digging and found out, that `yajl-ruby` 1.2.2 from 5th April 
2017 solves this issue as well and it looks like if you start from scratch, 
this version will be pulled instead of 1.2.1 which was pulled before.
At least, now, I cannot reproduce the issue any more starting from a clean 
checkout.

I assume, we could also set this as a direct dependency to be sure...

> flink-web doesn't build with ruby 2.4
> -------------------------------------
>
>                 Key: FLINK-7361
>                 URL: https://issues.apache.org/jira/browse/FLINK-7361
>             Project: Flink
>          Issue Type: Bug
>          Components: Project Website
>            Reporter: Nico Kruber
>            Assignee: Nico Kruber
>
> The dependencies pulled in by the old jekyll version do not build with ruby 
> 2.4 and fail with something like
> {code}
> yajl_ext.c:881:22: error: 'rb_cFixnum' undeclared (first use in this 
> function); did you mean 'rb_isalnum'?
> {code}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to