[ 
https://issues.apache.org/jira/browse/FLINK-7795?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16345955#comment-16345955
 ] 

Ted Yu edited comment on FLINK-7795 at 3/13/18 1:27 AM:
--------------------------------------------------------

error-prone has JDK 8 dependency.


was (Author: yuzhih...@gmail.com):
error-prone has JDK 8 dependency .

> Utilize error-prone to discover common coding mistakes
> ------------------------------------------------------
>
>                 Key: FLINK-7795
>                 URL: https://issues.apache.org/jira/browse/FLINK-7795
>             Project: Flink
>          Issue Type: Improvement
>          Components: Build System
>            Reporter: Ted Yu
>            Priority: Major
>
> http://errorprone.info/ is a tool which detects common coding mistakes.
> We should incorporate into Flink build process.
> Here are the dependencies:
> {code}
>     <dependency>
>       <groupId>com.google.errorprone</groupId>
>       <artifactId>error_prone_annotation</artifactId>
>       <version>${error-prone.version}</version>
>       <scope>provided</scope>
>     </dependency>
>     <dependency>
>       <!--mvn dependency:analyze says this is not used but compile fails
>             without it; going w/ the compiler's view of the world-->
>       <groupId>com.google.auto.service</groupId>
>       <artifactId>auto-service</artifactId>
>       <version>1.0-rc3</version>
>       <optional>true</optional>
>     </dependency>
>     <dependency>
>       <groupId>com.google.errorprone</groupId>
>       <artifactId>error_prone_check_api</artifactId>
>       <version>${error-prone.version}</version>
>       <scope>provided</scope>
>       <exclusions>
>         <exclusion>
>           <groupId>com.google.code.findbugs</groupId>
>           <artifactId>jsr305</artifactId>
>         </exclusion>
>       </exclusions>
>     </dependency>
>     <dependency>
>       <groupId>com.google.errorprone</groupId>
>       <artifactId>javac</artifactId>
>       <version>9-dev-r4023-3</version>
>       <scope>provided</scope>
>     </dependency>
>   </dependencies>
> {code}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to