[
https://issues.apache.org/jira/browse/FLINK-13351?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16890002#comment-16890002
]
Louis Xu commented on FLINK-13351:
----------------------------------
[~jark] [~lzljs3620320] What do you think about this improvement? Remove
duplicate code or add CompositeRelDataType to blink-planner. And how about
assign this issue to me?
> duplicate case ROW match in FlinkTypeFactory.toLogicalType
> ----------------------------------------------------------
>
> Key: FLINK-13351
> URL: https://issues.apache.org/jira/browse/FLINK-13351
> Project: Flink
> Issue Type: Bug
> Components: Table SQL / Planner
> Affects Versions: 1.9.0, 1.10.0
> Reporter: Louis Xu
> Priority: Major
> Fix For: 1.10.0
>
>
> FlinkTypeFactory.toLogicalType() in flink-table-planner-blink module has
> duplicate case Row match in line 482-489.
> I also look in FlinkTypeFactory in flink-table-planner, it also have 2 case
> Row match. But one of match types is 'CompositeRelDataType' which defined
> only in flink-table-planner module.
--
This message was sent by Atlassian JIRA
(v7.6.14#76016)