[ 
https://issues.apache.org/jira/browse/FLINK-17032?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17091440#comment-17091440
 ] 

Chesnay Schepler commented on FLINK-17032:
------------------------------------------

When trying to introduce a naming convention it is generally a good idea to 
formulate some properties that the convention should fulfill.

For example, one such property might be the when sorting the list of resources 
alphabetically, all resources belonging a cluster should be grouped together. 
This is what the cluster-id at the start provides.

Another property that I would consider desirable is that all resources with the 
same type are grouped together. With the current proposal this would not 
necessarily be the case, since the resource type either a) doesn't exist at all 
(for pods) or is at the end (svc, config).

> Naming convention unification for all the Kubernetes Resources
> --------------------------------------------------------------
>
>                 Key: FLINK-17032
>                 URL: https://issues.apache.org/jira/browse/FLINK-17032
>             Project: Flink
>          Issue Type: Improvement
>          Components: Deployment / Kubernetes
>    Affects Versions: 1.10.0
>            Reporter: Canbin Zheng
>            Priority: Minor
>             Fix For: 1.11.0
>
>
> Currently, the naming rules are different among the Kubernetes resources we 
> have created, the rules are as follows:
>  # The Deployment: ${clusterId}
>  # The internal Service: ${clusterId}
>  # The external Service: ${clusterId}-rest
>  # The Flink Configuration ConfigMap: flink-config-${clusterId}
>  # The Hadoop Configuration ConfigMap: hadoop-config-${clusterId}
>  # The JobManager Pod: ${clusterId}\-${random string}-${random string}
>  # The TaskManager Pod: 
> ${clusterId}\-taskmanager-${currentMaxAttemptId}-${currentMaxPodId}
> In the future, we would add other Kubernetes resources, and it would be 
> better to have a unified naming convention for all of them.
> This ticket proposes the following naming convention:
>  * The Deployment: ${clusterId}
>  * The internal Service: ${clusterId}-internal-svc
>  * The external Service: ${clusterId}-external-svc
>  * The Flink Configuration ConfigMap: ${clusterId}-flink-config
>  * The Hadoop Configuration ConfigMap: ${clusterId}-hadoop-config
>  * The JobManager Pod: ${clusterId}\-${random string}-${random string}
>  * The TaskManager Pod: 
> ${clusterId}\-taskmanager-${currentMaxAttemptId}-${currentMaxPodId}



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Reply via email to