[ 
https://issues.apache.org/jira/browse/FLINK-23976?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17405557#comment-17405557
 ] 

Shen Zhu commented on FLINK-23976:
----------------------------------

Hey Seth([~sjwiesman] ),

I have some ideas for this ticket.

*startingTime*
(1) If job is in terminal state, return -1
(2) If job doesn't have RUNNING state, return 0
(3) If job is not in terminal state and has RUNNING state, return the diff 
between RUNNING and CREATED

*cancelingTime*
(1) If job is in terminal state, return -1
(2) If job doesn't have CANCELING state, return 0
(3) If job is not in terminal state and has CANCELING state, then check if job 
has CANCELD state, if yes then return the diff between CANCELD and CALCELING, 
if no then return System.currentTimeMillis() - CALCELING timestamp.

What do you think about it, if it looks good do you, could you please assign 
this ticket to me?

Thanks for your help!

> Add additional availability timing metrics to Job lifecycle events
> ------------------------------------------------------------------
>
>                 Key: FLINK-23976
>                 URL: https://issues.apache.org/jira/browse/FLINK-23976
>             Project: Flink
>          Issue Type: Improvement
>          Components: Runtime / Metrics
>            Reporter: Seth Wiesman
>            Priority: Major
>
> Flink currently contains a number of availability lifecycle metrics[1] 
> showing how long it takes to move through different job status'. We propose 
> adding two additional metrics; startingTime, and cancellingTime (open to 
> bikeshedding on the metric names). 
>  
>  * startingTime is the time it takes a job to get to running. 
>  * cancellingTime is the time spent in status CANCELLING 
>  
>  
> [1]https://ci.apache.org/projects/flink/flink-docs-master/docs/ops/metrics/#availability



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Reply via email to