Github user aljoscha commented on the issue:
    I think most of the proposed renames are good. One thing that would be good 
to change is to remove `SnapshotProvider` and just have that method directly on 
    I really like the separation between the user facing state store and the 
backend. I've been meaning to change that for keyed state as well, i.e. the 
user only gets a way to access state and not all the methods for snapshotting, 
closing, etc. from the backend.
    When I say I like the changes, I mean everything except that they have 
`Operator` in all of them. In the end, all state is at an operator, plus there 
is the existing interface `OperatorState` that is an alias for `ValueState`. I 
don't have a good alternative now, but I think the `Operator` could be 

If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at or file a JIRA ticket
with INFRA.

Reply via email to