ASF GitHub Bot commented on FLINK-4379:

Github user aljoscha commented on the issue:

    I think most of the proposed renames are good. One thing that would be good 
to change is to remove `SnapshotProvider` and just have that method directly on 
    I really like the separation between the user facing state store and the 
backend. I've been meaning to change that for keyed state as well, i.e. the 
user only gets a way to access state and not all the methods for snapshotting, 
closing, etc. from the backend.
    When I say I like the changes, I mean everything except that they have 
`Operator` in all of them. In the end, all state is at an operator, plus there 
is the existing interface `OperatorState` that is an alias for `ValueState`. I 
don't have a good alternative now, but I think the `Operator` could be 

> Add Rescalable Non-Partitioned State
> ------------------------------------
>                 Key: FLINK-4379
>                 URL: https://issues.apache.org/jira/browse/FLINK-4379
>             Project: Flink
>          Issue Type: New Feature
>          Components: State Backends, Checkpointing
>            Reporter: Ufuk Celebi
>            Assignee: Stefan Richter
> This issue is associated with [FLIP-8| 
> https://cwiki.apache.org/confluence/display/FLINK/FLIP-8%3A+Rescalable+Non-Partitioned+State].

This message was sent by Atlassian JIRA

Reply via email to