Robert Metzger commented on FLINK-4194:

The method {{KinesisDeserializationSchema.isEndOfStream}} is not part of the 
1.1.x release: 

So if you want, you can rename it to {{isEndOfShard()}}. I think that renaming 
makes sense, because it describes the behavior more accurately.

> Implement isEndOfStream() for KinesisDeserializationSchema
> ----------------------------------------------------------
>                 Key: FLINK-4194
>                 URL: https://issues.apache.org/jira/browse/FLINK-4194
>             Project: Flink
>          Issue Type: New Feature
>          Components: Kinesis Connector
>            Reporter: Robert Metzger
>            Assignee: Tzu-Li (Gordon) Tai
>             Fix For: 1.2.0
> **Original JIRA title: KinesisDeserializationSchema.isEndOfStream() is never 
> called. The corresponding part of the code has been commented out with 
> reference to this JIRA.**
> The Kinesis connector does not respect the 
> {{KinesisDeserializationSchema.isEndOfStream()}} method.
> The purpose of this method is to stop consuming from a source, based on input 
> data.

This message was sent by Atlassian JIRA

Reply via email to