Greg Hogan commented on FLINK-1890:

Do we still want this documented or can we close this issue?

> Add note to docs that ReadFields annotations are currently not evaluated
> ------------------------------------------------------------------------
>                 Key: FLINK-1890
>                 URL: https://issues.apache.org/jira/browse/FLINK-1890
>             Project: Flink
>          Issue Type: Wish
>          Components: DataSet API
>            Reporter: Stefan Bunk
>            Priority: Minor
> In the Scala API, you have the option to declare forwarded fields via the
> {{withForwardedFields}} method.
> It would be nice to have sth. similar for read fields, as otherwise one needs 
> to create a class, which I personally try to avoid for readability.
> Maybe grouping all annotations in one function and have a first parameter 
> indicating the type of annotation is also an option, if you plan on adding 
> more annotations and want to keep the interface smaller.

This message was sent by Atlassian JIRA

Reply via email to