Danish created FLINK-40692:
------------------------------
Summary: [Model] Use default model version from server when no
version is defined in model config
Key: FLINK-40692
URL: https://issues.apache.org/jira/browse/FLINK-40692
Project: Flink
Issue Type: Improvement
Reporter: Danish
When we don't define `model-version` in `CREATE MODEL` SQL, it tends to create
URL with `version: latest`. i.e.
https://\{model endpoint}/v2/models/\{model name}/versions/latest/infer
This is not necessarily the case for all model servers in KServe protocol and
it fails for them. The protocol defines that if there is no version defined, we
fall back to using the default model defined by the server itself. i.e. the url
does not contain any version info
https://\{model endpoint}/v2/models/\{model name}/infer
The server model can define either the latest or any other model version to be
used when no version is mentioned using server side policies.
--
This message was sent by Atlassian Jira
(v8.20.10#820010)