VladBanar opened a new issue, #3439: URL: https://github.com/apache/fluss/issues/3439
### Search before asking - [x] I searched in the [issues](https://github.com/apache/fluss/issues) and found nothing similar. ### Motivation Currently, POJO field names must exactly match Fluss table column names. This creates rigid naming constraints that conflict with Java naming conventions (camelCase) and database naming conventions (snake_case). ### Solution Introduce @ColumnName annotation for POJO fields to map them to table columns with different names. The annotation is processed during POJO inspection in PojoType.of(), storing properties keyed by their mapped column names. This enables seamless bidirectional conversion between POJOs (with idiomatic Java naming) and Fluss tables (with any naming convention), with zero runtime overhead and full backward compatibility. ### Anything else? _No response_ ### Willingness to contribute - [x] I'm willing to submit a PR! -- This is an automated message from the Apache Git Service. To respond to the message, please log on to GitHub and use the URL above to go to the specific comment. To unsubscribe, e-mail: [email protected] For queries about this service, please contact Infrastructure at: [email protected]
