fresh-borzoni opened a new issue, #636: URL: https://github.com/apache/fluss-rust/issues/636
### Search before asking - [x] I searched in the [issues](https://github.com/apache/fluss-rust/issues) and found nothing similar. ### Description We have TableId, PartitionId, and BucketId aliases in lib.rs, but snapshot_id is still spelled i64 everywhere. Adding a matching SnapshotId alias would keep things consistent and make signatures easier to read. A few hand-written sites to update: LakeSnapshot (metadata/table.rs), KvSnapshotLeaseForBucket (metadata/kv_snapshot_lease.rs), and the get_kv_snapshot_metadata / get_lake_snapshot request constructors. ### Willingness to contribute - [ ] I'm willing to submit a PR! -- This is an automated message from the Apache Git Service. To respond to the message, please log on to GitHub and use the URL above to go to the specific comment. To unsubscribe, e-mail: [email protected] For queries about this service, please contact Infrastructure at: [email protected]
