[ 
https://issues.apache.org/jira/browse/GEODE-3062?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Kirk Lund reopened GEODE-3062:
------------------------------

Reverting this fix from develop. It is now causing several DUnit failures:
{noformat}
:geode-core:distributedTest

org.apache.geode.management.internal.configuration.ClusterConfigStartMemberDUnitTest
 > testStartServerWithSingleGroup FAILED
    org.apache.geode.test.dunit.RMIException: While invoking 
org.apache.geode.management.internal.configuration.ClusterConfig$$Lambda$35/1101639581.run
 in VM 1 running on Host 0c6aaa5a2b35 with 4 VMs
        at org.apache.geode.test.dunit.VM.invoke(VM.java:377)
        at org.apache.geode.test.dunit.VM.invoke(VM.java:347)
        at org.apache.geode.test.dunit.VM.invoke(VM.java:292)
        at org.apache.geode.test.dunit.rules.MemberVM.invoke(MemberVM.java:43)
        at 
org.apache.geode.management.internal.configuration.ClusterConfig.verifyServer(ClusterConfig.java:149)
        at 
org.apache.geode.management.internal.configuration.ClusterConfig.verify(ClusterConfig.java:87)
        at 
org.apache.geode.management.internal.configuration.ClusterConfigStartMemberDUnitTest.testStartServerWithSingleGroup(ClusterConfigStartMemberDUnitTest.java:59)

        Caused by:
        java.lang.AssertionError: 
        Expecting actual not to be null

org.apache.geode.management.internal.configuration.ClusterConfigDistributionDUnitTest
 > testIndexAndAsyncEventQueueCommands FAILED
    java.lang.AssertionError: Suspicious strings were written to the log during 
this run.
    Fix the strings or use IgnoredException.addIgnoredException to ignore.
    -----------------------------------------------------------------------
    Found suspect string in log4j at line 1274

    [error 2017/06/14 21:09:48.652 UTC <RMI TCP Connection(2)-172.17.0.4> 
tid=0x1e] While instantiating a  com.qcdunit.QueueCommandsDUnitTestListener

org.apache.geode.management.internal.configuration.ClusterConfigStartMemberDUnitTest
 > testStartServerWithMultipleGroup FAILED
    org.apache.geode.test.dunit.RMIException: While invoking 
org.apache.geode.management.internal.configuration.ClusterConfig$$Lambda$35/1101639581.run
 in VM 1 running on Host 0c6aaa5a2b35 with 4 VMs
        at org.apache.geode.test.dunit.VM.invoke(VM.java:377)
        at org.apache.geode.test.dunit.VM.invoke(VM.java:347)
        at org.apache.geode.test.dunit.VM.invoke(VM.java:292)
        at org.apache.geode.test.dunit.rules.MemberVM.invoke(MemberVM.java:43)
        at 
org.apache.geode.management.internal.configuration.ClusterConfig.verifyServer(ClusterConfig.java:149)
        at 
org.apache.geode.management.internal.configuration.ClusterConfig.verify(ClusterConfig.java:87)
        at 
org.apache.geode.management.internal.configuration.ClusterConfigStartMemberDUnitTest.testStartServerWithMultipleGroup(ClusterConfigStartMemberDUnitTest.java:77)

        Caused by:
        java.lang.AssertionError: 
        Expecting actual not to be null

org.apache.geode.management.internal.configuration.ClusterConfigImportDUnitTest 
> testImportClusterConfig FAILED
    org.apache.geode.test.dunit.RMIException: While invoking 
org.apache.geode.management.internal.configuration.ClusterConfig$$Lambda$47/1506617398.run
 in VM 1 running on Host 72a6f599ae60 with 4 VMs
        at org.apache.geode.test.dunit.VM.invoke(VM.java:377)
        at org.apache.geode.test.dunit.VM.invoke(VM.java:347)
        at org.apache.geode.test.dunit.VM.invoke(VM.java:292)
        at org.apache.geode.test.dunit.rules.MemberVM.invoke(MemberVM.java:43)
        at 
org.apache.geode.management.internal.configuration.ClusterConfig.verifyServer(ClusterConfig.java:149)
        at 
org.apache.geode.management.internal.configuration.ClusterConfig.verify(ClusterConfig.java:87)
        at 
org.apache.geode.management.internal.configuration.ClusterConfigImportDUnitTest.testImportClusterConfig(ClusterConfigImportDUnitTest.java:113)

        Caused by:
        java.lang.AssertionError: 
        Expecting actual not to be null

org.apache.geode.management.internal.configuration.ClusterConfigDeployJarDUnitTest
 > testDeployToNoServer FAILED
    org.apache.geode.test.dunit.RMIException: While invoking 
org.apache.geode.management.internal.configuration.ClusterConfig$$Lambda$49/1828498145.run
 in VM 1 running on Host 20afe4eda954 with 4 VMs
        at org.apache.geode.test.dunit.VM.invoke(VM.java:377)
        at org.apache.geode.test.dunit.VM.invoke(VM.java:347)
        at org.apache.geode.test.dunit.VM.invoke(VM.java:292)
        at org.apache.geode.test.dunit.rules.MemberVM.invoke(MemberVM.java:43)
        at 
org.apache.geode.management.internal.configuration.ClusterConfig.verifyServer(ClusterConfig.java:149)
        at 
org.apache.geode.management.internal.configuration.ClusterConfig.verify(ClusterConfig.java:87)
        at 
org.apache.geode.management.internal.configuration.ClusterConfigDeployJarDUnitTest.testDeployToNoServer(ClusterConfigDeployJarDUnitTest.java:63)

        Caused by:
        java.lang.AssertionError: 
        Expecting actual not to be null

org.apache.geode.management.internal.configuration.ClusterConfigImportDUnitTest 
> testImportWithRunningServer FAILED
    org.apache.geode.test.dunit.RMIException: While invoking 
org.apache.geode.management.internal.configuration.ClusterConfig$$Lambda$47/1506617398.run
 in VM 1 running on Host 72a6f599ae60 with 4 VMs
        at org.apache.geode.test.dunit.VM.invoke(VM.java:377)
        at org.apache.geode.test.dunit.VM.invoke(VM.java:347)
        at org.apache.geode.test.dunit.VM.invoke(VM.java:292)
        at org.apache.geode.test.dunit.rules.MemberVM.invoke(MemberVM.java:43)
        at 
org.apache.geode.management.internal.configuration.ClusterConfig.verifyServer(ClusterConfig.java:149)
        at 
org.apache.geode.management.internal.configuration.ClusterConfig.verify(ClusterConfig.java:87)
        at 
org.apache.geode.management.internal.configuration.ClusterConfigImportDUnitTest.testImportWithRunningServer(ClusterConfigImportDUnitTest.java:96)

        Caused by:
        java.lang.AssertionError: 
        Expecting actual not to be null

org.apache.geode.management.internal.configuration.ClusterConfigDeployJarDUnitTest
 > testUndeployWithServerBounce FAILED
    org.apache.geode.test.dunit.RMIException: While invoking 
org.apache.geode.management.internal.configuration.ClusterConfig$$Lambda$49/1828498145.run
 in VM 3 running on Host 20afe4eda954 with 4 VMs
        at org.apache.geode.test.dunit.VM.invoke(VM.java:377)
        at org.apache.geode.test.dunit.VM.invoke(VM.java:347)
        at org.apache.geode.test.dunit.VM.invoke(VM.java:292)
        at org.apache.geode.test.dunit.rules.MemberVM.invoke(MemberVM.java:43)
        at 
org.apache.geode.management.internal.configuration.ClusterConfig.verifyServer(ClusterConfig.java:149)
        at 
org.apache.geode.management.internal.configuration.ClusterConfig.verify(ClusterConfig.java:87)
        at 
org.apache.geode.management.internal.configuration.ClusterConfigDeployJarDUnitTest.testUndeployWithServerBounce(ClusterConfigDeployJarDUnitTest.java:259)

        Caused by:
        java.lang.AssertionError: 
        Expecting actual not to be null

org.apache.geode.security.SecurityClusterConfigDUnitTest > 
serverWithDifferentPostProcessorShouldThrowGemFireConfigException FAILED
    org.apache.geode.test.dunit.RMIException: While invoking 
org.apache.geode.test.dunit.rules.LocatorServerStartupRule$$Lambda$18/2087525298.call
 in VM 0 running on Host 329271a7a790 with 4 VMs
        at org.apache.geode.test.dunit.VM.invoke(VM.java:377)
        at org.apache.geode.test.dunit.VM.invoke(VM.java:347)
        at org.apache.geode.test.dunit.VM.invoke(VM.java:315)
        at 
org.apache.geode.test.dunit.rules.LocatorServerStartupRule.startLocatorVM(LocatorServerStartupRule.java:96)
        at 
org.apache.geode.security.SecurityClusterConfigDUnitTest.before(SecurityClusterConfigDUnitTest.java:62)

        Caused by:
        org.apache.geode.security.AuthenticationRequiredException: Failed to 
find credentials from [172.17.0.5(locator-0:922:locator)<ec>:32770]

org.apache.geode.security.SecurityClusterConfigDUnitTest > 
serverWithDifferentSecurityManagerShouldThrowGemFireConfigException FAILED
    org.apache.geode.test.dunit.RMIException: While invoking 
org.apache.geode.test.dunit.rules.LocatorServerStartupRule$$Lambda$18/2087525298.call
 in VM 0 running on Host 329271a7a790 with 4 VMs
        at org.apache.geode.test.dunit.VM.invoke(VM.java:377)
        at org.apache.geode.test.dunit.VM.invoke(VM.java:347)
        at org.apache.geode.test.dunit.VM.invoke(VM.java:315)
        at 
org.apache.geode.test.dunit.rules.LocatorServerStartupRule.startLocatorVM(LocatorServerStartupRule.java:96)
        at 
org.apache.geode.security.SecurityClusterConfigDUnitTest.before(SecurityClusterConfigDUnitTest.java:62)

        Caused by:
        org.apache.geode.security.AuthenticationRequiredException: Failed to 
find credentials from [172.17.0.5(locator-0:922:locator)<ec>:32770]
{noformat}


> security-manager property is ignored when using cluster config
> --------------------------------------------------------------
>
>                 Key: GEODE-3062
>                 URL: https://issues.apache.org/jira/browse/GEODE-3062
>             Project: Geode
>          Issue Type: Bug
>          Components: configuration
>            Reporter: Kirk Lund
>            Assignee: Kirk Lund
>             Fix For: 1.3.0
>
>
> The fix for GEODE-2632 moves the creation of the SecurityService from 
> GemFireCacheImpl to InternalDistributedSystem so that membership can properly 
> use it. Membership needs to use SecurityService for peer-to-peer 
> authentication which occurs before the Cache exists.
> Cluster config is requested and applied during initialization of a 
> GemFireCacheImpl instance. So if security-manager property has a value in 
> cluster config, it will be ignored.
> Potential short-term fix for this bug is to allow the GemFireCacheImpl object 
> to have its own SecurityService which is created from cluster config 
> properties. 
> This only affects servers because secondary locators do not use cluster 
> config (see GEODE-2315).



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to