[ 
https://issues.apache.org/jira/browse/GEODE-4654?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16363113#comment-16363113
 ] 

Anthony Baker commented on GEODE-4654:
--------------------------------------

Thanks for this report.  I have good news, we just updated our dependencies to 
use JNA 4.5.0!  See GEODE-4622.  This will be available when v1.5.0 is released 
in commit 
[https://github.com/apache/geode/commit/c076bef6471f43e227531c4829dd90b32931dd23.]

 

> Have to use JNA-4.5.0 to support Geode on s390x
> -----------------------------------------------
>
>                 Key: GEODE-4654
>                 URL: https://issues.apache.org/jira/browse/GEODE-4654
>             Project: Geode
>          Issue Type: Wish
>          Components: general
>            Reporter: Chakravarthy Gopi
>            Priority: Major
>
> Os : S390X
>  Apache Geode version : 1.3.0
> {color:#205081}Apache Geode uses JNA-4.0.0.{color}
> {color:#205081} Below test case failures are observed on S390x which are not 
> present in case of X86 as JNA version(4.0.0) doesn't support s390x.{color}
>  1. org.apache.geode.internal.process.NativeProcessUtilsTest > 
> isProcessAlive_livePid_returnsTrue.
>  2. org.apache.geode.internal.process.NativeProcessUtilsTest > 
> isProcessAlive_deadPid_returnsFalse.
> {color:#205081}In future , If Geode source code is modified such that it uses 
> JNA-4.5.0(supports S390X too) , the above test case failures may get 
> resolved.{color}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to