Cyrille Artho commented on GEODE-3584:

If we want to preserve API compatibility, probably the best solution is to add 
a couple of wrappers that preserve the old method names as deprecated methods.

This leads to some ugly code, such as @deprecated getHostname \{ getHostName(); 
}, but will provide a consistent API front-end for new code without breaking 
old code.

> Refactor ServerLauncher and LocatorLauncher to eliminate code duplication
> -------------------------------------------------------------------------
>                 Key: GEODE-3584
>                 URL: https://issues.apache.org/jira/browse/GEODE-3584
>             Project: Geode
>          Issue Type: Improvement
>          Components: gfsh
>    Affects Versions: 1.2.0
>            Reporter: Kenneth Howe
>            Priority: Major
>         Attachments: GEODE-3584-1, GEODE-3584-WIP, GEODE-3584-WIP-2, 
> GEODE-3584-WIP-3, GEODE-3584-WIP-4
> There is some duplication of code in the Launcher classes that can be 
> eliminated. Both classes have methods such as getBindAddress (called 
> getServerBindAddress in ServerLauncher) that could be hoisted into  
> AbstractLauncher class that they both extend. The same goes for the inner 
> State classes of the Launchers; they have methods that could be moved to 
> AbstractLauncher.ServiceState.

This message was sent by Atlassian JIRA

Reply via email to