Darrel Schneider created GEODE-5059:

             Summary: AbstractRegionMap.basicPut should be refactored
                 Key: GEODE-5059
                 URL: https://issues.apache.org/jira/browse/GEODE-5059
             Project: Geode
          Issue Type: Improvement
          Components: regions
            Reporter: Darrel Schneider

Recently the AbstractRegionMap.basicPut method was refactored into many smaller 
methods that all take an instance of RegionMapPutContext.

These methods should be moved to another class (it could be named RegionMapPut) 
and the RegionMapPutContext could go away since the RegionMapPut instance could 
keep all the state of the put operation.


This message was sent by Atlassian JIRA

Reply via email to