[
https://issues.apache.org/jira/browse/GEODE-5502?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]
nabarun closed GEODE-5502.
--------------------------
> Cluster configuration can contain member-specific gateway receiver
> definitions which cause members to fail to start during rolling
> ----------------------------------------------------------------------------------------------------------------------------------
>
> Key: GEODE-5502
> URL: https://issues.apache.org/jira/browse/GEODE-5502
> Project: Geode
> Issue Type: Bug
> Components: configuration
> Reporter: Barry Oglesby
> Assignee: Barry Oglesby
> Priority: Major
> Labels: pull-request-available, swat
> Fix For: 1.7.0
>
> Time Spent: 1h 10m
> Remaining Estimate: 0h
>
> In versions before 1.4.0, cluster configuration could contain multiple
> member-specific gateway receiver definitions like:
> {noformat}
> <cache>
> <gateway-receiver hostname-for-senders="123.12.12.12"/>
> <gateway-receiver hostname-for-senders="123.12.12.11"/>
> </cache>
> {noformat}
> Starting in 1.4.0, multiple receivers are no longer allowed, so a
> configuration like this causes the member to throw an exception and fail to
> start.
> These member-specific receivers should be removed before sending the cluster
> configuration to new members to avoid attempting to create multiple receivers
> in a single member.
> Note: In this case, the member will start with no receivers.
--
This message was sent by Atlassian JIRA
(v7.6.3#76005)