Eric Shu created GEODE-6477:
-------------------------------
Summary: GII provider should indicate that it does not persist the
requester's new persistent id when processing PrepareNewPersistentMemberMessage
during shutdown
Key: GEODE-6477
URL: https://issues.apache.org/jira/browse/GEODE-6477
Project: Geode
Issue Type: Bug
Components: regions
Reporter: Eric Shu
Currently, provide does not persist the requester's new persistent id during
shutdown but it does not send a message to indicate this. The requester could
then request gii from the provider and then persists its new persistent id and
assume the provider has persisted its new id. And then it is being shut down as
well.
The end result is a requester could not be restarted if provider was recovered
first (shut down all case), as provider does not know the requester's new
persistent id and ConflictingPersistentDataException is raised.
--
This message was sent by Atlassian JIRA
(v7.6.3#76005)