[
https://issues.apache.org/jira/browse/GEODE-6573?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16810153#comment-16810153
]
ASF subversion and git services commented on GEODE-6573:
--------------------------------------------------------
Commit a4ad6617ecf0cc6139d4df483c5100fa50b0d53f in geode's branch
refs/heads/develop from Darrel Schneider
[ https://gitbox.apache.org/repos/asf?p=geode.git;h=a4ad661 ]
GEODE-6573: move methods from ConnectionManager to Connection (#3375)
Connection now has default implementations of getWrappedConnection,
activate, and passivate. ConnectionManager no longer has these methods.
> ConnectionManager has some methods on it that should be on Connection instead
> -----------------------------------------------------------------------------
>
> Key: GEODE-6573
> URL: https://issues.apache.org/jira/browse/GEODE-6573
> Project: Geode
> Issue Type: Improvement
> Components: client/server
> Reporter: Darrel Schneider
> Assignee: Darrel Schneider
> Priority: Major
> Time Spent: 20m
> Remaining Estimate: 0h
>
> org.apache.geode.cache.client.internal.pooling.ConnectionManager has three
> methods on it that do not belong: getConnection(Connection),
> activate(Connection), passivate(Connection, boolean).
> All three of these methods should instead be on the Connection interface.
> None of them have anything to do with the manager.
> getConnection(Connection) is requesting the wrapped connection from a
> connection. So a better name for it would be getWrappedConnection.
> Not all implementations of the Connection interface need to support wrapping
> or activation but those implementations can just implement these operations
> as a noop.
--
This message was sent by Atlassian JIRA
(v7.6.3#76005)