Diane Hardman created GEODE-2003:

             Summary: Executing a function using REST API fails with full 
package-qualified name
                 Key: GEODE-2003
                 URL: https://issues.apache.org/jira/browse/GEODE-2003
             Project: Geode
          Issue Type: Bug
          Components: rest (dev)
            Reporter: Diane Hardman
             Fix For: 1.1.0-incubating

While verifying integrated security using for all REST API's, I used gfsh to 
start a locator, a server, and create a single region with 2 data entries. I 
then wrote and deployed a simple function (io.build.test.Sample).
In a separate terminal I was able to successfully get a list of the function 
using the GET API, but when I tried to execute the function using the following 
curl -u dataWriter:123 -X POST -i 
I get the following exception:
"org.apache.geode.cache.execute.FunctionException: Function named io.build.test 
is not registered to FunctionService"
Note: the name of the function, Sample, was dropped in the exception message.
When I implemented the getId() method for the function to shorten the name to 
'foo', the same POST API worked successfully:
curl -u dataWriter:123 -X POST -i http:80/gemfire-api/v1/functions/foo

Is there a limit to the length or format for the function name with the POST 

This message was sent by Atlassian JIRA

Reply via email to