[ 
https://issues.apache.org/jira/browse/HAWQ-1045?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Shivram Mani updated HAWQ-1045:
-------------------------------
    Description: 
This is a requirement from Ambari integration. Side by side installation 
scenario to do HAWQ upgrade and verification.
The following rpm names and packaging strategy was agreed upon during the 
meeting with HAWQ, HAWQ-Ambari team and [~rvs]

    o pxf-3.0.1.0-1088.el6.noarch.rpm (vrpm, creates symlink /usr/lib/pxf and 
/etc/pxf/conf, dependencies: pxf-hdfs-3.0.1.0-1088, pxf-hive-3.0.1.0-1088, 
pxf-hbase-3.0.1.0-1088)
    o pxf-hdf-3.0.1.0-1088.el6.noarch.rpm
    o pxf-json-3.0.1.0-1088.el6.noarch.rpm
    o pxf-hbase-3.0.1.0-1088.el6.noarch.rpm
    o pxf-hive-3.0.1.0-1088.el6.noarch.rpm
    o pxf-service-3.0.1.0-1088.el6.noarch.rpm (dependency: apache-tomcat-7.0.62)

pxf-hive and pxf-hbase will no longer have strict rpm dependency on hive and 
hbase respectively.
Create and update the necessary rpm spec files to produce the above mentioned 
rpms.

  was:
This is a requirement from Ambari integration. Side by side installation 
scenario to do HAWQ upgrade and verification.
The following rpm names and packaging strategy was agreed upon during the 
meeting with HAWQ-Ambari team members and [~rvs]

    o pxf-3.0.1.0-1088.el6.noarch.rpm (vrpm, creates symlink, dependency: 
pxf-service_3_0_1_0-3.0.1.0-1088)
    o pxf-service_3_0_1_0-3.0.1.0-1088.el6.noarch.rpm (dependency: 
apache-tomcat-7.0.62, pxf-hdfs_3_0_1_0-3.0.1.0-1088, 
pxf-json_3_0_1_0-3.0.1.0-1088)
    o pxf-hdfs_3_0_1_0-3.0.1.0-1088.el6.noarch.rpm
    o pxf-json_3_0_1_0-3.0.1.0-1088.el6.noarch.rpm

    o pxf-hbase-3.0.1.0-1088.el6.noarch.rpm (vrpm, dependency: 
pxf-hbase_3_0_1_0-3.0.1.0-1088)
    o pxf-hbase_3_0_1_0-3.0.1.0-1088.el6.noarch.rpm

    o pxf-hive-3.0.1.0-1088.el6.noarch.rpm (vrpm, dependency: 
pxf-hive_3_0_1_0-3.0.1.0-1088)
    o pxf-hive_3_0_1_0-3.0.1.0-1088.el6.noarch.rpm

Create and update the necessary rpm spec files to produce the above mentioned 
rpms.


> Update PXF rpm to include virtual RPM
> -------------------------------------
>
>                 Key: HAWQ-1045
>                 URL: https://issues.apache.org/jira/browse/HAWQ-1045
>             Project: Apache HAWQ
>          Issue Type: Task
>          Components: Build, PXF
>            Reporter: Goden Yao
>            Assignee: Shivram Mani
>             Fix For: 2.0.1.0-incubating
>
>
> This is a requirement from Ambari integration. Side by side installation 
> scenario to do HAWQ upgrade and verification.
> The following rpm names and packaging strategy was agreed upon during the 
> meeting with HAWQ, HAWQ-Ambari team and [~rvs]
>     o pxf-3.0.1.0-1088.el6.noarch.rpm (vrpm, creates symlink /usr/lib/pxf and 
> /etc/pxf/conf, dependencies: pxf-hdfs-3.0.1.0-1088, pxf-hive-3.0.1.0-1088, 
> pxf-hbase-3.0.1.0-1088)
>     o pxf-hdf-3.0.1.0-1088.el6.noarch.rpm
>     o pxf-json-3.0.1.0-1088.el6.noarch.rpm
>     o pxf-hbase-3.0.1.0-1088.el6.noarch.rpm
>     o pxf-hive-3.0.1.0-1088.el6.noarch.rpm
>     o pxf-service-3.0.1.0-1088.el6.noarch.rpm (dependency: 
> apache-tomcat-7.0.62)
> pxf-hive and pxf-hbase will no longer have strict rpm dependency on hive and 
> hbase respectively.
> Create and update the necessary rpm spec files to produce the above mentioned 
> rpms.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to