[ 
https://issues.apache.org/jira/browse/HAWQ-1514?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16119343#comment-16119343
 ] 

Hongxu Ma commented on HAWQ-1514:
---------------------------------

Hi Yi, 
In my tests, openssl >= 1.0.1 is enough. 
Because tde need AES-CTR-256 algorithm, I googled some info: seems it's only 
available since OpenSSL v1.0.1.

But your 1.0.21 test failed is a bit strange, I will check it later.


> TDE feature makes libhdfs3 require openssl1.1
> ---------------------------------------------
>
>                 Key: HAWQ-1514
>                 URL: https://issues.apache.org/jira/browse/HAWQ-1514
>             Project: Apache HAWQ
>          Issue Type: Task
>          Components: libhdfs
>            Reporter: Yi Jin
>            Assignee: Radar Lei
>             Fix For: 2.3.0.0-incubating
>
>
> New TDE feature delivered in libhdfs3 requires specific version of openssl, 
> at least per my test, 1.0.21 does not work, and 1.1 source code built library 
> passed.
> So maybe we need some build and installation instruction improvement. 



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to