[ 
https://issues.apache.org/jira/browse/HBASE-3641?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13006726#comment-13006726
 ] 

stack commented on HBASE-3641:
------------------------------

Patch looks odd:

{code}
     public long getHitCachingCount() {
-      return hitCachingCount.get();
+      return hitCount.get();
     }
{code}

The method is called getHitCachingCount and it was returning state of 
hitCachingCount... which seems right?

> LruBlockCache.CacheStats.getHitCount() is not using the correct variable
> ------------------------------------------------------------------------
>
>                 Key: HBASE-3641
>                 URL: https://issues.apache.org/jira/browse/HBASE-3641
>             Project: HBase
>          Issue Type: Bug
>          Components: io
>    Affects Versions: 0.90.1, 0.92.0
>            Reporter: Jonathan Gray
>            Assignee: Jonathan Gray
>             Fix For: 0.90.2, 0.92.0
>
>         Attachments: HBASE-3641-v1.patch
>
>
> {code}
>     public long getHitCount() {
>       return hitCachingCount.get();
>     }
> {code}
> This should be {{hitCount.get()}}

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Reply via email to