[ 
https://issues.apache.org/jira/browse/HBASE-9261?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13845522#comment-13845522
 ] 

rajeshbabu commented on HBASE-9261:
-----------------------------------

bq. postCompleteBatchMutate -> Will it be fine to pass the 
MiniBatchOperationInProgress<Mutation> miniBatchOp also?
It will be better to pass miniBatchOp. Upload new patch for this.

bq.I would say pls have a better name for this API.
I am not getting any other name. Can any one please suggest better name for 
postCompleteBatchMutate hook?
Thanks.

> Add cp hooks after {start|close}RegionOperation in batchMutate
> --------------------------------------------------------------
>
>                 Key: HBASE-9261
>                 URL: https://issues.apache.org/jira/browse/HBASE-9261
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: rajeshbabu
>            Assignee: rajeshbabu
>         Attachments: HBASE-9261.patch, HBASE-9261_v2.patch, 
> HBASE-9261_v3.patch, HBASE-9261_v4.patch, HBASE-9261_v5.patch
>
>
> These hooks helps for checking Resources(blocking memstore size) and 
> necessary locking on index region while performing batch of mutations. 



--
This message was sent by Atlassian JIRA
(v6.1.4#6159)

Reply via email to