[ 
https://issues.apache.org/jira/browse/HBASE-12126?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14153923#comment-14153923
 ] 

Andrew Purtell commented on HBASE-12126:
----------------------------------------

bq. With the above code in patch, coprocessors like AccessController serving as 
region endpoint and as an observer for Regionserver will now also be registered 
as endpoint for region server

I think we need a new interface to avoid that. Region endpoints aren't going to 
function correctly if invoked from a different context. 

How about:
{code}
    if (SingletonCoprocessorService.class.isAssignableFrom(c)) {
          this.regionServerServices.registerService(((CoprocessorService) 
impl).getService());
          break;
    }
{code}
?

Maybe there's a better name but it's not totally off because there will only be 
one service instance of this type per regionserver.

> Region server coprocessor endpoint
> ----------------------------------
>
>                 Key: HBASE-12126
>                 URL: https://issues.apache.org/jira/browse/HBASE-12126
>             Project: HBase
>          Issue Type: Bug
>          Components: Coprocessors
>    Affects Versions: 0.98.6
>            Reporter: Virag Kothari
>         Attachments: HBASE-12126-0.98.patch
>
>
> Primary use case in HBASE-12125 but being able to make endpoint calls against 
> region server can be useful in general.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to