[ 
https://issues.apache.org/jira/browse/HBASE-15359?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15173428#comment-15173428
 ] 

Eshcar Hillel commented on HBASE-15359:
---------------------------------------

In the umbrella jira [~stack] says
bq. We want CellBlocks right? Not HFile blocks? 
and
bq. The HFile instance (with all its great possibilities) seams like something 
too complex for this simple task of storing the data flat. Agree.

>From this I conjecture segments will not be implemented as an HFile instance. 

rollback is declared in Store.java and MemStore.java and implemented in HStore 
ans AbstractMemStore. In the meanwhile it is also supported by MutableSegment, 
but can be removed once it is cleaned everywhere else.

> Simplifying Segment hierarchy
> -----------------------------
>
>                 Key: HBASE-15359
>                 URL: https://issues.apache.org/jira/browse/HBASE-15359
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: Eshcar Hillel
>            Assignee: Eshcar Hillel
>             Fix For: 0.98.18
>
>         Attachments: HBASE-14918-FIX-SEGMENT.patch
>
>
> Now that it is clear that no memstore segment will be implemented as an 
> HFIle, and that all segments store their data in some representation of 
> CellSet (skip-list or flat), the segment hierarchy can be much simplified.
> The attached patch includes only 3 classes in the hierarchy:
> Segment - comprises most of the state and implementation
> MutableSegment - extends API with add and rollback functionality
> ImmutableSegment - extends API with key-value scanner for snapshot
> SegmentScanner is the scanner for all types of segments. 
> In addition, the option to rollback immutable segment in the memstore is 
> disabled.
> This code would allow us to make progress independently in the compaction 
> subtask (HBASE-14920) and the flat index representation subtask 
> (HBASE-14921). It also means that the new immutable segment can reuse the 
> existing SegmentScanner, instead of implementing a new scanner.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to