[ 
https://issues.apache.org/jira/browse/HBASE-16179?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Ted Yu updated HBASE-16179:
---------------------------
    Attachment: 16179.v4.txt

With patch v4, tests in hbase-spark pass against Spark 2.0 release.

Still need to figure out how to support Spark 1.6 at the same time.

> Fix compilation errors when building hbase-spark against Spark 2.0
> ------------------------------------------------------------------
>
>                 Key: HBASE-16179
>                 URL: https://issues.apache.org/jira/browse/HBASE-16179
>             Project: HBase
>          Issue Type: Bug
>            Reporter: Ted Yu
>            Assignee: Ted Yu
>         Attachments: 16179.v0.txt, 16179.v1.txt, 16179.v1.txt, 16179.v4.txt
>
>
> I tried building hbase-spark module against Spark-2.0 snapshot and got the 
> following compilation errors:
> http://pastebin.com/bg3w247a
> Some Spark classes such as DataTypeParser and Logging are no longer 
> accessible to downstream projects.
> hbase-spark module should not depend on such classes.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to