[ 
https://issues.apache.org/jira/browse/HBASE-16656?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15514386#comment-15514386
 ] 

Ted Yu commented on HBASE-16656:
--------------------------------

{code}
+    if(setName == null) {
+      setName = "backup";
{code}
Should "backup" be defined as constant ?
{code}
+      if(name1.equals(name2)) {
{code}
nit: insert space between if and '('
{code}
+    String backupId = (setName == null? 
BackupRestoreConstants.BACKUPID_PREFIX: setName) +
+        "_"+EnvironmentEdgeManager.currentTime();
{code}
If BACKUPID_PREFIX is used, there would be double underscore's.

> BackupID must include backup set name
> -------------------------------------
>
>                 Key: HBASE-16656
>                 URL: https://issues.apache.org/jira/browse/HBASE-16656
>             Project: HBase
>          Issue Type: Improvement
>            Reporter: Vladimir Rodionov
>            Assignee: Vladimir Rodionov
>         Attachments: HBASE-16656-v1.patch
>
>
> Default backup set name is "backup". If we do backup for a backup set 
> "SomeSetName", by default, backup id will be generated in a form:
>  *SomeSetName_timestamp*.
> The goal is to separate backup images between different sets. 
> The history command will be updated and the new command - merge will use this 
> backup names (prefixes)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to