[
https://issues.apache.org/jira/browse/HBASE-16489?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15567351#comment-15567351
]
Enis Soztutar commented on HBASE-16489:
---------------------------------------
- {{hbase-native-client/core/configuration-test.cc}} does not assert anything,
just prints out values, so it is not a unit test. Please make sure that there
are at least some tests.
- Please use a better name for this map. It is not a single property. Why are
we typedefing this anyway?
+using HBASE_CONF_PROPERTY = std::map<std::string, std::string>;
- This for loop is not how we do substitute variables in the java code:
{code}
+ for (int i = 0; i < MAX_SUBSTS; i++) {
{code}
Instead of blindly iterating over the values 20 times, we do substitute
matching at the get() time. There is a subtle difference in the case that
Configuration is a dynamic object in Java, so the substituted variables can
change on runtime.
- we need a version of Get without deprecated key handling:
{code}
+const std::string HBaseConfiguration::Get(const std::string &name,
+ const std::string &default_value) {
{code}
> Configuration parsing
> ---------------------
>
> Key: HBASE-16489
> URL: https://issues.apache.org/jira/browse/HBASE-16489
> Project: HBase
> Issue Type: Sub-task
> Reporter: Sudeep Sunthankar
> Assignee: Sudeep Sunthankar
> Attachments: HBASE-16489.HBASE-14850.v1.patch
>
>
> Reading hbase-site.xml is required to read various properties viz.
> zookeeper-quorum, client retires etc. We can either use Apache Xerces or
> Boost libraries.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)