[
https://issues.apache.org/jira/browse/HBASE-16743?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15617230#comment-15617230
]
Hudson commented on HBASE-16743:
--------------------------------
FAILURE: Integrated in Jenkins build HBase-1.4 #504 (See
[https://builds.apache.org/job/HBase-1.4/504/])
HBASE-16743 TestSimpleRpcScheduler#testCoDelScheduling is broke (antonov: rev
ea5b0a05d692cfaccc004d030df9d81fb4f7f47e)
* (edit)
hbase-server/src/test/java/org/apache/hadoop/hbase/ipc/TestSimpleRpcScheduler.java
> TestSimpleRpcScheduler#testCoDelScheduling is broke
> ---------------------------------------------------
>
> Key: HBASE-16743
> URL: https://issues.apache.org/jira/browse/HBASE-16743
> Project: HBase
> Issue Type: Bug
> Components: rpc
> Affects Versions: 1.3.0
> Reporter: stack
> Assignee: Mikhail Antonov
> Fix For: 1.3.0
>
> Attachments: HBASE-16743.branch-1.patch
>
>
> The testCoDelScheduling test is broke. Here are some notes on it. I have
> disabled it in the HBASE-15638 shading patch.
> {code}
> I don't get this test. When I time this test, the minDelay is > 2 * codel
> delay from the get go. So we are always overloaded. The test below would seem
> to complete the queuing of all the CallRunners inside the codel check
> interval. I don't think we are skipping codel checking. Second, I think this
> test has been broken since HBASE-16089 Add on FastPath for CoDel went in.
> The thread name we were looking for was the name BEFORE we updated: i.e.
> "RpcServer.CodelBQ.default.handler". But same patch changed the name of the
> codel fastpath thread to: new
> FastPathBalancedQueueRpcExecutor("CodelFPBQ.default", handlerCount,
> numCallQueues...
> Codel is hard to test. This test is going to be flakey given it all
> timer-based. Disabling for now till chat
> {code}
> FYI [~mantonov]
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)