[ 
https://issues.apache.org/jira/browse/HBASE-17315?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15796993#comment-15796993
 ] 

Enis Soztutar commented on HBASE-17315:
---------------------------------------

Thanks Sudeep for the updated patch. 

Is it possible to cut this patch in half so that it is easier to commit this 
sooner. Let's leave the ResultScanner and all scan related functionality out of 
this patch, and focus on the Table and Client changes. Table can only contain 
Get() and Close() methods. Let's do the ResultScanner changes as a different 
patch. 

A couple of comments: 
 - no need for {{cleanup_connection_on_close_}}. This is from a different era 
in the Java land. 
 - Instead of these: 
{code}
+  const std::shared_ptr<hbase::LocationCache> &LocationCache() const;
+  const std::shared_ptr<hbase::RpcClient> &RpcClient() const;
{code}
pass them to the Table at construction time. 
 - Client::GetTable() should be named Client::Table() 
 - Is this right? 
{code}
+  client_.reset(new Client(*table.client_));
{code}
 - You can remove this
{{TODO check if consistency is STRONG or TIMELINE and fire Get() accordingly}} 

> [C++] HBase Client and Table Implementation
> -------------------------------------------
>
>                 Key: HBASE-17315
>                 URL: https://issues.apache.org/jira/browse/HBASE-17315
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: Sudeep Sunthankar
>            Assignee: Sudeep Sunthankar
>         Attachments: HBASE-17315.HBASE-14850.v1.patch, 
> HBASE-17315.HBASE-14850.v2.patch, HBASE-17315.HBASE-14850.v3.patch
>
>
> Consists of Client and Table implementation which will be used to call the 
> corresponding client methods i.e Get, Gets, Scan etc. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to