[ 
https://issues.apache.org/jira/browse/HBASE-18389?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16091817#comment-16091817
 ] 

Chia-Ping Tsai commented on HBASE-18389:
----------------------------------------

bq.  Does it make sense to you?
It makes sense to me.
{noformat}
+  public static long sizeOfPartOfByteArray(int len) {
+    return memoryLayout.sizeOfByteArray(len);
   }
{noformat}
Should we make these methods have same name?

{noformat}
[WARNING] 
/testptch/hbase/hbase-common/src/main/java/org/apache/hadoop/hbase/util/ClassSize.java:476:
 warning - Missing closing '}' character for inline tag: "{@link 
#sizeOfPartOfByteArray(int) instead."
{noformat}
Please fix the doc.


> Remove byte[] from formal parameter of sizeOf() of ClassSize, 
> ClassSize.MemoryLayout and ClassSize.UnsafeLayout
> ---------------------------------------------------------------------------------------------------------------
>
>                 Key: HBASE-18389
>                 URL: https://issues.apache.org/jira/browse/HBASE-18389
>             Project: HBase
>          Issue Type: Bug
>          Components: util
>            Reporter: Xiang Li
>            Assignee: Xiang Li
>            Priority: Minor
>         Attachments: HBASE-18389.master.000.patch, 
> HBASE-18389.master.001.patch
>
>
> In ClassSize class and its internal static class, sizeOf() function has 2 
> formal parameters: byte[] b and int len. But the function's internal logic 
> does not use or refer to byte[] b. Could be removed.
> {code:title=hbase-common/src/main/java/org/apache/hadoop/hbase/util/ClassSize.java|borderStyle=solid}
> // Class of ClassSize
> public static long sizeOf(byte[] b, int len) {
>   return memoryLayout.sizeOf(b, len);
> }
> // Class of ClassSize.MemoryLayout
> long sizeOf(byte[] b, int len) {
>   return align(arrayHeaderSize() + len);
> }
> // Class of ClassSize.UnsafeLayout
> long sizeOf(byte[] b, int len) {
>   return align(arrayHeaderSize() + len * 
> UnsafeAccess.theUnsafe.ARRAY_BYTE_INDEX_SCALE);
> }
> {code}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to