Mike Drob commented on HBASE-18142:

Not a fan of the {{rubocop:disable}} directives. We can leave those errors 
present and work through them incrementally in future issues and then disable 
the checks once we decide that there really is nothing to be done.

With these test changes, there's no coverage remaining on {{delete()}}, it's 
all on {{deleteall()}}.

The new ruby-lint warnings look like false positives to me. The rubocop 
warnings should be addressed (and I think they were addressed in v6, looks 

> Deletion of a cell deletes the previous versions too
> ----------------------------------------------------
>                 Key: HBASE-18142
>                 URL: https://issues.apache.org/jira/browse/HBASE-18142
>             Project: HBase
>          Issue Type: Bug
>          Components: API, shell
>    Affects Versions: 3.0.0
>            Reporter: Karthick
>            Assignee: ChunHao
>              Labels: beginner
>             Fix For: 3.0.0, 2.0.0-alpha-2
>         Attachments: HBASE-18142.master.v0.patch, 
> HBASE-18142.master.v1.patch, HBASE-18142.master.v2.patch, 
> HBASE-18142.master.v3.patch, HBASE-18142.master.v4.patch, 
> HBASE-18142.master.v5.patch, HBASE-18142.master.v6.patch
> When I tried to delete a cell using it's timestamp in the Hbase Shell, the 
> previous versions of the same cell also got deleted. But when I tried the 
> same using the Java API, then the previous versions are not deleted and I can 
> retrive the previous values.
> https://github.com/apache/hbase/blob/master/hbase-client/src/main/java/org/apache/hadoop/hbase/client/Delete.java
> see this file to fix the issue. This method (public Delete addColumns(final 
> byte [] family, final byte [] qualifier, final long timestamp)) only deletes 
> the current version of the cell. The previous versions are not deleted.

This message was sent by Atlassian JIRA

Reply via email to