[ 
https://issues.apache.org/jira/browse/HBASE-18469?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16116026#comment-16116026
 ] 

Yu Li commented on HBASE-18469:
-------------------------------

bq. For multi actions, the row actions can be on the same row.
True, so maybe "totalRegionActionRequestCount" and "requestRegionActionCount" 
are better names?

bq. Also, it is possible to add/increment the request row counter somehow at 
the higher level in batch, not one row a time?
For multi, we're already doing this:
{code}
-      this.requestCount.add(regionAction.getActionCount());
+      this.requestRowsCount.add(regionAction.getActionCount());
{code}
For scan, it's hard to foresee which limit will be reached first, so we better 
increase the counter after each successful scan.next call, right?

> Correct  RegionServer metric of  totalRequestCount
> --------------------------------------------------
>
>                 Key: HBASE-18469
>                 URL: https://issues.apache.org/jira/browse/HBASE-18469
>             Project: HBase
>          Issue Type: Improvement
>          Components: metrics, regionserver
>    Affects Versions: 1.2.0
>            Reporter: Shibin Zhang
>            Assignee: Yu Li
>            Priority: Critical
>             Fix For: 2.0.0, 1.4.0
>
>         Attachments: HBASE-18469.patch
>
>
> when i get the metric ,i found  this three metric may be have some error  as 
> follow :
>     "totalRequestCount" : 17541,
>     "readRequestCount" : 17483,
>     "writeRequestCount" : 1633,



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to