[ 
https://issues.apache.org/jira/browse/HBASE-3584?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13185265#comment-13185265
 ] 

Zhihong Yu commented on HBASE-3584:
-----------------------------------

w.r.t. the coprocessor pre hooks, I think option 2 is better.
{code}
+ * The mutations are in performed in the order in which they
+ * were added.
{code}
The above should read 'are performed'.

For atomicMutation(), maybe mutateAtomically is a better name for the method ?
{code}
+          internalDelete((Delete)d, HConstants.DEFAULT_CLUSTER_ID, 
d.getWriteToWAL(), w);
+        } else {
+          throw new DoNotRetryIOException("Action must be Put or Delete");  
{code}
Type cast above isn't needed. Please include m in the exception message.
                
> We need to atomically put/delete/increment in one call
> ------------------------------------------------------
>
>                 Key: HBASE-3584
>                 URL: https://issues.apache.org/jira/browse/HBASE-3584
>             Project: HBase
>          Issue Type: Bug
>            Reporter: ryan rawson
>            Assignee: Lars Hofhansl
>         Attachments: 3584-v1.txt
>
>
> Right now we have the following calls:
> put(Put)
> delete(Delete)
> increment(Increments)
> But we cannot combine all of the above in a single call, complete with a 
> single row lock.  It would be nice to do that.
> It would also allow us to do a CAS where we could do a put/increment if the 
> check succeeded.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Reply via email to