[ 
https://issues.apache.org/jira/browse/HBASE-17980?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Kuan-Po Tseng updated HBASE-17980:
----------------------------------
    Attachment: HBASE-17980.master.v0.patch

1. Introduce RegionInfo class. HRegionInfo implements RegionInfo.
2. Deprecate HRegionInfo to be removed in 3.0
3. Interface RegionInfo contain all of the read-only methods of HRegionInfo
4. Add "RegionInfo Builder"
5. Rename UnmodifyableHRegionInfo.java to ImmutableHRegionInfo.java
6. Replace HRegionInfo in #getOnlineRegions and #getOfflineRegions in 
HBaseAdmin.java with ImmutableHRegionInfo

> Any HRegionInfo we give out should be immutable
> -----------------------------------------------
>
>                 Key: HBASE-17980
>                 URL: https://issues.apache.org/jira/browse/HBASE-17980
>             Project: HBase
>          Issue Type: Sub-task
>    Affects Versions: 2.0.0
>            Reporter: Chia-Ping Tsai
>            Assignee: Kuan-Po Tseng
>              Labels: beginner
>             Fix For: 2.0.0
>
>         Attachments: HBASE-17980.master.v0.patch
>
>
> This is similar to HBASE-15583.
> # Introduce RegionInfo class. HRegionInfo will extend RegionInfo.
> # Deprecate HRegionInfo to be removed in 3.0
> # RegionInfo contain all of the read-only methods of HRegionInfo
> # Add "RegionInfo Builder"



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to