[ 
https://issues.apache.org/jira/browse/HBASE-19678?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16307564#comment-16307564
 ] 

BELUGA BEHR commented on HBASE-19678:
-------------------------------------

As mentioned in [HBASE-19679], this is actually still open.  I just posted my 
patch for a different issue under this ticket.

> HBase Admin security capabilities should be represented as a Set
> ----------------------------------------------------------------
>
>                 Key: HBASE-19678
>                 URL: https://issues.apache.org/jira/browse/HBASE-19678
>             Project: HBase
>          Issue Type: Improvement
>          Components: hbase
>    Affects Versions: 3.0.0
>            Reporter: BELUGA BEHR
>            Assignee: BELUGA BEHR
>            Priority: Minor
>             Fix For: 2.0.0-beta-2
>
>         Attachments: HBASE-19678.1.patch
>
>
> {code:title=org.apache.hadoop.hbase.client.Admin}
>   /**
>    * Return the set of supported security capabilities.
>    * @throws IOException
>    * @throws UnsupportedOperationException
>    */
>   List<SecurityCapability> getSecurityCapabilities() throws IOException;
> {code}
> The comment says a "set" but it returns a List.  A Set would be the most 
> appropriate data structure here, an immutable one perhaps, because the code 
> that interacts with it looks up information using the _contains_ method which 
> would be served well by a Set.  Please change this interface to return a Set.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to