[
https://issues.apache.org/jira/browse/HBASE-19717?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16316669#comment-16316669
]
Josh Elser edited comment on HBASE-19717 at 1/8/18 5:49 PM:
------------------------------------------------------------
bq. Well, the only reason to keep it as a separate list I see is that in
DataBlockEncoding may have some 'reserved' block encodings for specific cases
that should not be tested in the regular way (like we had COPY_KEY for
benchmarks).
What if we introduce a {{userValues()}} static-method on DBE? Something that
implicitly differentiates between "all" and "user-facing" DBEncodings?
Edit: I am not sold on the name {{userValues()}} I suggested. Would be happy
with a better name than that :P
was (Author: elserj):
bq. Well, the only reason to keep it as a separate list I see is that in
DataBlockEncoding may have some 'reserved' block encodings for specific cases
that should not be tested in the regular way (like we had COPY_KEY for
benchmarks).
What if we introduce a {{userValues()}} static-method on DBE? Something that
implicitly differentiates between "all" and "user-facing" DBEncodings?
> IntegrationTestDDLMasterFailover is using outdated values for
> DataBlockEncoding
> -------------------------------------------------------------------------------
>
> Key: HBASE-19717
> URL: https://issues.apache.org/jira/browse/HBASE-19717
> Project: HBase
> Issue Type: Bug
> Components: integration tests
> Affects Versions: 2.0.0-beta-1
> Reporter: Romil Choksi
> Assignee: Sergey Soldatov
> Fix For: 2.0.0-beta-2
>
> Attachments: HBASE-19717-add-branch-2.patch,
> HBASE-19717-branch-2.patch
>
>
> We have removed PREFIX_TREE data block encoding, but
> IntegrationTestDDLMasterFailover is still using it.
--
This message was sent by Atlassian JIRA
(v6.4.14#64029)