[ 
https://issues.apache.org/jira/browse/HBASE-20189?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Sakthi updated HBASE-20189:
---------------------------
    Attachment:     (was: hbase-20189.patch)

> Typo in Required Java Version error message while building HBase.
> -----------------------------------------------------------------
>
>                 Key: HBASE-20189
>                 URL: https://issues.apache.org/jira/browse/HBASE-20189
>             Project: HBase
>          Issue Type: Bug
>          Components: build
>            Reporter: Sakthi
>            Assignee: Sakthi
>            Priority: Trivial
>              Labels: beginner, beginners
>
> Change 'requirs' to 'requires'. See below:
> {code:java}
> $ mvn clean install -DskipTests
> ...
> [WARNING] Rule 2: org.apache.maven.plugins.enforcer.RequireJavaVersion failed 
> with message:
> Java is out of date.
>   HBase requirs at least version 1.8 of the JDK to properly build from source.
>   You appear to be using an older version. You can use either "mvn -version" 
> or
>   "mvn enforcer:display-info" to verify what version is active.
>   See the reference guide on building for more information: 
> http://hbase.apache.org/book.html#build
> {code}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to