[ 
https://issues.apache.org/jira/browse/HBASE-20279?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16425860#comment-16425860
 ] 

Sean Busbey commented on HBASE-20279:
-------------------------------------

need to check for hfiles that are using PREFIX_TREE data block encoding.

> [tooling] check for incompatible environment for HBase 2.0 upgrade
> ------------------------------------------------------------------
>
>                 Key: HBASE-20279
>                 URL: https://issues.apache.org/jira/browse/HBASE-20279
>             Project: HBase
>          Issue Type: Sub-task
>          Components: documentation, tooling
>    Affects Versions: 2.0.0
>            Reporter: Sean Busbey
>            Priority: Critical
>
> from [~stack] on HBASE-19158:
> {quote}
> bq. Server failure. HBase can still read HFiles written in the older version 
> 2 format.
> Need a script that user can run pre-upgrade.
> {quote}
> Additional commentary from [~busbey]
> In addition to the config check stack mentions, such a tool could check
> * other problematic configs, like those for master-hosts-regions
> * inconsistent configs due to changed defaults (I think we should have some 
> smell-tests around the change in default for hbase.security.authorization)
> * (optionally) check for unreadable WALs
> * (optionally) check for unreadable hfiles



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to