[ 
https://issues.apache.org/jira/browse/HBASE-20257?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16537054#comment-16537054
 ] 

Sean Busbey commented on HBASE-20257:
-------------------------------------

sure. lemme start by getting a current precommit run.

> hbase-spark should not depend on com.google.code.findbugs.jsr305
> ----------------------------------------------------------------
>
>                 Key: HBASE-20257
>                 URL: https://issues.apache.org/jira/browse/HBASE-20257
>             Project: HBase
>          Issue Type: Task
>          Components: build, spark
>    Affects Versions: 3.0.0
>            Reporter: Ted Yu
>            Assignee: Artem Ervits
>            Priority: Minor
>              Labels: beginner
>         Attachments: HBASE-20257.v01.patch, HBASE-20257.v02.patch, 
> HBASE-20257.v03.patch, HBASE-20257.v04.patch
>
>
> The following can be observed in the build output of master branch:
> {code}
> [WARNING] Rule 0: org.apache.maven.plugins.enforcer.BannedDependencies failed 
> with message:
> We don't allow the JSR305 jar from the Findbugs project, see HBASE-16321.
> Found Banned Dependency: com.google.code.findbugs:jsr305:jar:1.3.9
> Use 'mvn dependency:tree' to locate the source of the banned dependencies.
> {code}
> Here is related snippet from hbase-spark/pom.xml:
> {code}
>     <dependency>
>       <groupId>com.google.code.findbugs</groupId>
>       <artifactId>jsr305</artifactId>
> {code}
> Dependency on jsr305 should be dropped.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to