[ 
https://issues.apache.org/jira/browse/HBASE-13442?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Andrew Kyle Purtell closed HBASE-13442.
---------------------------------------

> Rename scanner caching to a more semantically correct term such as row limit
> ----------------------------------------------------------------------------
>
>                 Key: HBASE-13442
>                 URL: https://issues.apache.org/jira/browse/HBASE-13442
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: Jonathan Lawlor
>            Priority: Major
>         Attachments: HBASE-13442-proposal.diff
>
>
> Caching acts more as a row limit now. By default in branch-1+, a Scan is 
> configured with (caching=Integer.MAX_VALUE, maxResultSize=2MB) so that we 
> service scans on the basis of buffer size rather than number of rows. As a 
> result, caching should now only be configured in instances where the user 
> knows that they will only need X rows. Thus, caching should be renamed to 
> something that is more semantically correct such as rowLimit.



--
This message was sent by Atlassian Jira
(v8.20.7#820007)

Reply via email to