[ 
https://issues.apache.org/jira/browse/HBASE-2611?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13402582#comment-13402582
 ] 

Zhihong Ted Yu commented on HBASE-2611:
---------------------------------------

Putting patch on review board helps.

{code}
+   * @param opList: list of Op to be executed as one trx.
{code}
'trx' -> 'transaction'
{code}
+    if(opList == null || opList.size() ==0)
{code}
Space between if and (.
{code}
+    }catch (InterruptedException ie) {
+      LOG.warn("multi call interrupted; process failed!" + ie);
{code}
Restore interrupt status for the thread (same for doMultiAndWatch). Space 
between } and catch.
{code}
+      LOG.warn("multi call failed! One of the passed ops has failed which 
result in the rolled back.");
{code}
Line length beyond 100.
{code}
+   * @return
+   */
+  public SortedMap<String, SortedSet<String>> copyDeadRSLogsWithMulti(
+      String deadRSZnode) {
{code}
javadoc for the return value.
{code}
+      LOG.warn("This is us! Skipping the processing as we might be closing 
down.");
{code}
Add deadRSZnodePath to the log.
{code}
+    RetryCounterFactory retryCounterFactory = new 
RetryCounterFactory(Integer.MAX_VALUE, 3 * 1000);
{code}
I don't think MAX_VALUE is a good choice.
{code}
+        SortedSet<String> logQueue = new TreeSet<String>();
{code}
Why is logQueue backed by a TreeSet ?
{code}
+        LOG.warn("KeeperException occurred in multi; " +
+            "seems some other regionserver took the logs before us.");
{code}
Add ke to the above message.
{code}
+        Op deleteOpForLog = Op.delete(zNodeForCurrentLog, -1);
+        znodesToWatch.add(logZnode);
+        opsList.add(createOpForLog);
+        opsList.add(deleteOpForLog);
{code}
Please reorder the above calls so that znodesToWatch.add() is after 
opsList.add() calls. This would make code more readable.
                
> Handle RS that fails while processing the failure of another one
> ----------------------------------------------------------------
>
>                 Key: HBASE-2611
>                 URL: https://issues.apache.org/jira/browse/HBASE-2611
>             Project: HBase
>          Issue Type: Sub-task
>          Components: replication
>            Reporter: Jean-Daniel Cryans
>            Assignee: Jean-Daniel Cryans
>         Attachments: HBase-2611-upstream-v1.patch
>
>
> HBASE-2223 doesn't manage region servers that fail while doing the transfer 
> of HLogs queues from other region servers that failed. Devise a reliable way 
> to do it.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Reply via email to