[ 
https://issues.apache.org/jira/browse/HBASE-7801?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13582788#comment-13582788
 ] 

Enis Soztutar commented on HBASE-7801:
--------------------------------------

For 0.94, it looks good, but for trunk I think we can merge writeToWAL and 
syncWAL into one enum. Smt like: 
{code}
message Mutate {
  required bytes row = 1;
  ....
  enum WriteGuarantee {
    SYNC_WAL  = 0, 
    ASYNC_WAL = 1,
    SKIP_WAL  = 2
  }
  optional WriteGuarantee writeGuarantee = 6 [default = SYNC_WAL];
{code}

I am sure, we can think of a better name than WriteGuarantee though. 

                
> Allow a deferred sync option per Mutation.
> ------------------------------------------
>
>                 Key: HBASE-7801
>                 URL: https://issues.apache.org/jira/browse/HBASE-7801
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: Lars Hofhansl
>            Assignee: Lars Hofhansl
>             Fix For: 0.96.0, 0.94.6
>
>         Attachments: 7801-0.94-v1.txt, 7801-0.94-v2.txt, 7801-0.96-v1.txt
>
>
> Won't have time for parent. But a deferred sync option on a per operation 
> basis comes up quite frequently.
> In 0.96 this can be handled cleanly via protobufs and 0.94 we can have a 
> special mutation attribute.
> For batch operation we'd take the safest sync option of any of the mutations. 
> I.e. if there is at least one that wants to be flushed we'd sync the batch, 
> if there's none of those but at least one that wants deferred flush we defer 
> flush the batch, etc.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Reply via email to