[ 
https://issues.apache.org/jira/browse/HIVE-18612?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Adam Szita updated HIVE-18612:
------------------------------
    Status: Patch Available  (was: In Progress)

> Build subprocesses under Yetus in Ptest use 1.7 jre instead of 1.8
> ------------------------------------------------------------------
>
>                 Key: HIVE-18612
>                 URL: https://issues.apache.org/jira/browse/HIVE-18612
>             Project: Hive
>          Issue Type: Bug
>          Components: Testing Infrastructure
>            Reporter: Adam Szita
>            Assignee: Adam Szita
>            Priority: Major
>         Attachments: HIVE-18612.0.patch
>
>
> As per this jira comment made by Yetus maven plugins that want to use 
> {{java}} executable are seeing a 1.7 java binary. In this particular case 
> Yetus sets JAVA_HOME to a 1.8 JDK installation, and thus maven uses that, but 
> any subsequent {{java}} executes will use the JRE which they see on PATH.
> This should be fixed by adding the proper java/bin (that of JAVA_HOME 
> setting) to PATH.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to