Alan Gates updated HIVE-19164:
    Status: Patch Available  (was: Open)

The attached patch fixes this, but is a big change to Driver's compile loop.  
The patch changes Driver to pass its config file to Hive (the class) when it 
calls Hive.get() to make sure Hive has the current config file.  This is what 
was causing the problem, as Hive had an old version of the config file from a 
previous test and Driver was calling Hive.get() rather than Hive.get(conf).

This seems like what we want, in order to make sure Hive has the right config 
file.  However, I am not sure since Driver has access to its own config file, 
the current session config file, and the current query config file.  I passed 
the Driver one, but I'm not sure that's the right choice.  Also, this code has 
not changed recently and may have other significant impacts since it's in 
Driver's main compile loop.

cc [~ashutoshc] and [~kgyrtkirk] who I think know this code much better than I.

> TestMetastoreVersion failures
> -----------------------------
>                 Key: HIVE-19164
>                 URL: https://issues.apache.org/jira/browse/HIVE-19164
>             Project: Hive
>          Issue Type: Sub-task
>          Components: Test
>            Reporter: Vineet Garg
>            Assignee: Alan Gates
>            Priority: Major
>             Fix For: 3.0.0
>         Attachments: HIVE-19164.patch
> Following tests are failing consistently and are reproducible on master:
> * testVersionMatching
> * testMetastoreVersion
> I tried debugging it and found that ObjectStore.getMSSchemaVersion() throws 
> an exception {{No matching version found}}. 
> To fetch schema version this method executes {code:sql} SELECT FROM 
> org.apache.hadoop.hive.metastore.model.MVersionTable {code} but for whatever 
> reason execution returns empty result set resulting in the exception. Both 
> test failures are due to this exception. I tried debugging the query 
> execution but didn't really go nowhere with it. I suspect this could be due 
> to recent metastore changes. I tried reproducing this outside test but with 
> no success.

This message was sent by Atlassian JIRA

Reply via email to