[ 
https://issues.apache.org/jira/browse/HIVE-19828?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16509497#comment-16509497
 ] 

Laszlo Bodor commented on HIVE-19828:
-------------------------------------

it is handled by HIVE-15976

> Rename UDFCurrentDB to GenericUDFCurrentDatabase
> ------------------------------------------------
>
>                 Key: HIVE-19828
>                 URL: https://issues.apache.org/jira/browse/HIVE-19828
>             Project: Hive
>          Issue Type: Task
>    Affects Versions: 3.0.0
>            Reporter: Laszlo Bodor
>            Assignee: Laszlo Bodor
>            Priority: Minor
>             Fix For: 4.0.0
>
>
> Currently, UDFCurrentDB extends GenericUDF, so it should follow the naming 
> convention: GenericUDFCurrentDB (otherwise it's misleading to have it this 
> way), or more accurately GenericUDFCurrentDatabase, as UDFs usually contain 
> the whole keyword (database), not just an abbreviation (db), and it doesn't 
> become too long in this case.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to