[ 
https://issues.apache.org/jira/browse/HIVE-21523?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16804748#comment-16804748
 ] 

Hive QA commented on HIVE-21523:
--------------------------------



Here are the results of testing the latest attachment:
https://issues.apache.org/jira/secure/attachment/12964089/HIVE-21523.03.patch

{color:red}ERROR:{color} -1 due to no test(s) being added or modified.

{color:green}SUCCESS:{color} +1 due to 15875 tests passed

Test results: 
https://builds.apache.org/job/PreCommit-HIVE-Build/16747/testReport
Console output: https://builds.apache.org/job/PreCommit-HIVE-Build/16747/console
Test logs: http://104.198.109.242/logs/PreCommit-HIVE-Build-16747/

Messages:
{noformat}
Executing org.apache.hive.ptest.execution.TestCheckPhase
Executing org.apache.hive.ptest.execution.PrepPhase
Executing org.apache.hive.ptest.execution.YetusPhase
Executing org.apache.hive.ptest.execution.ExecutionPhase
Executing org.apache.hive.ptest.execution.ReportingPhase
{noformat}

This message is automatically generated.

ATTACHMENT ID: 12964089 - PreCommit-HIVE-Build

> Break up DDLTask - extract View related operations
> --------------------------------------------------
>
>                 Key: HIVE-21523
>                 URL: https://issues.apache.org/jira/browse/HIVE-21523
>             Project: Hive
>          Issue Type: Sub-task
>          Components: Hive
>    Affects Versions: 3.1.1
>            Reporter: Miklos Gergely
>            Assignee: Miklos Gergely
>            Priority: Major
>             Fix For: 4.0.0
>
>         Attachments: HIVE-21523.01.patch, HIVE-21523.02.patch, 
> HIVE-21523.03.patch
>
>
> DDLTask is a huge class, more than 5000 lines long. The related DDLWork is 
> also a huge class, which has a field for each DDL operation it supports. The 
> goal is to refactor these in order to have everything cut into more 
> handleable classes under the package  org.apache.hadoop.hive.ql.exec.ddl:
>  * have a separate class for each operation
>  * have a package for each operation group (database ddl, table ddl, etc), so 
> the amount of classes under a package is more manageable
>  * make all the requests (DDLDesc subclasses) immutable
>  * DDLTask should be agnostic to the actual operations
>  * right now let's ignore the issue of having some operations handled by 
> DDLTask which are not actual DDL operations (lock, unlock, desc...)
> In the interim time when there are two DDLTask and DDLWork classes in the 
> code base the new ones in the new package are called DDLTask2 and DDLWork2 
> thus avoiding the usage of fully qualified class names where both the old and 
> the new classes are in use.
> Step #3: extract all the view related operations from the old DDLTask, and 
> move them under the new package.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to