[ 
https://issues.apache.org/jira/browse/HIVE-21881?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16866455#comment-16866455
 ] 

Hive QA commented on HIVE-21881:
--------------------------------



Here are the results of testing the latest attachment:
https://issues.apache.org/jira/secure/attachment/12972051/HIVE-21881.03.patch

{color:red}ERROR:{color} -1 due to build exiting with an error

Test results: 
https://builds.apache.org/job/PreCommit-HIVE-Build/17624/testReport
Console output: https://builds.apache.org/job/PreCommit-HIVE-Build/17624/console
Test logs: http://104.198.109.242/logs/PreCommit-HIVE-Build-17624/

Messages:
{noformat}
Executing org.apache.hive.ptest.execution.TestCheckPhase
Tests exited with: Exception: Patch URL 
https://issues.apache.org/jira/secure/attachment/12972051/HIVE-21881.03.patch 
was found in seen patch url's cache and a test was probably run already on it. 
Aborting...
{noformat}

This message is automatically generated.

ATTACHMENT ID: 12972051 - PreCommit-HIVE-Build

> Break up DDLTask - extract rest of the operations
> -------------------------------------------------
>
>                 Key: HIVE-21881
>                 URL: https://issues.apache.org/jira/browse/HIVE-21881
>             Project: Hive
>          Issue Type: Sub-task
>          Components: Hive
>    Affects Versions: 3.1.1
>            Reporter: Miklos Gergely
>            Assignee: Miklos Gergely
>            Priority: Major
>              Labels: refactor-ddl
>             Fix For: 4.0.0
>
>         Attachments: HIVE-21881.01.patch, HIVE-21881.02.patch, 
> HIVE-21881.03.patch
>
>
> DDLTask is a huge class, more than 5000 lines long. The related DDLWork is 
> also a huge class, which has a field for each DDL operation it supports. The 
> goal is to refactor these in order to have everything cut into more 
> handleable classes under the package  org.apache.hadoop.hive.ql.exec.ddl:
>  * have a separate class for each operation
>  * have a package for each operation group (database ddl, table ddl, etc), so 
> the amount of classes under a package is more manageable
>  * make all the requests (DDLDesc subclasses) immutable
>  * DDLTask should be agnostic to the actual operations
>  * right now let's ignore the issue of having some operations handled by 
> DDLTask which are not actual DDL operations (lock, unlock, desc...)
> In the interim time when there are two DDLTask and DDLWork classes in the 
> code base the new ones in the new package are called DDLTask2 and DDLWork2 
> thus avoiding the usage of fully qualified class names where both the old and 
> the new classes are in use.
> Step #11: extract the operations that left from the old DDLTask, and move 
> them under the new packages.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to